I have a quest to go to the Secluded Lodge (which I've already been to previously for other quests) to retrieve blood. Trying to keep this as spoiler free as possible. Anyway, when I travel to that location and try to enter, I get this error and get kicked out to the Main Menu. This also happened at one other location earlier in the game but I can't remember which. I just gave up on that one though and didn't try to troubleshoot much:

I have Bag of Tricks and Heroes of Stolen Lands installed.

With Bag of Tricks I've tried to stick with minimally impacting things such as exp gain increase, giving gold, and the fast rest. I've dabbled in a few other areas but have avoided any of those "don't do this without saving first" hoping to avoid corrupting my game.

I've loaded my save onto two different computers, one which didn't even have Bag of Tricks installed and I get the same result. So I'm worried my save may just be corrupted and I'm outta luck. I sent an email to Owlcat yesterday but haven't heard back yet (which is totally fine, didn't expect a response within 2 hours). In the meantime I thought I'd reach out here and see if anyone else has experienced this and can maybe confirm my suspicions. I tried searching on the forums here but wasn't sure how to find this particular issue other than "JSON" or "Crash to Menu".

Troubleshooting Done:
Rolled back Graphics drivers
Clean install of latest Graphics drivers
Validated Game files multiple times (I'm using the Steam version)
Copied Save to a different computer with no mods installed (same result)
Updated BIOS and any other drivers I haven't updated recently
Entered different areas nearby, saved, then tried entering Secluded Lodge again
Took everyone out of the party but my main character
Curled up in fetal position and cried for ~15 minutes
Rested at the zone, then tried to enter
Rested nearby, then tried to enter
Disabled mods
Restarted computer multiple times
Restarted game multiple times
Prayed (IRL) to any and all deities I could think of
Googled the error message
Turned off clothing animations or cloaks or whatever that option was
Probably a lot more I'm not remembering..